
Transition to ArcGIS Pro
Oklahoma State Training



Introductions

• DATAMARK Technologies
• Oklahoma GIS Committee Members
• Class Attendees



Agenda
• ArcGIS Pro Overview – 30 minutes
• Getting Started with a Pro Project – 30 minutes
• Map Interface – 1 hour
• Displaying Data – 1 hour

• Symbology
• Labeling

• Database Management – 1.5 hour
• Field Management
• Domain Management
• Topology

• Exploring Attribute Tables – 1 hour
• Queries
• Field Calculations
• Joins, Summaries, Statistics

• Editing Tools – 1.5 hours
• Key differences of standard tools
• Geoprocessing tools
• Advanced Editing tools

• Best Practices and OK Toolkit Overview - 30 minutes



ArcMap and ArcCatalog 
Review
Module 1



Esri’s ArcGIS Desktop (ArcMap) is a suite of GIS applications designed for mapping, spatial 
analysis, and data management.
• ArcGIS Desktop includes two main applications:

• ArcMap - Traditional desktop GIS application for map creation, spatial analysis, and data 
editing. Supports advanced cartography and geoprocessing tools.

• ArcCatalog - Application for managing GIS data that provides a centralized view of GIS 
content, allowing users to browse, organize, and manage spatial data and metadata. 
• Separate program that can be opened independently from ArcMap or accessed 

through ArcMap directly
ArcGIS Desktop offers three license levels:
• Basic: Core mapping and visualization (cannot perform Topology or Versioning)
• Standard: Adds advanced editing and geodatabase management
• Advanced: Full suite of analysis and automation tools

ArcMap Overview



Scheduled to retire on March 1, 2026, with no future releases planned!

It’s time to…

ArcMap Retirement Party



ArcGIS Pro Overview
Module 1



What is ArcGIS Pro?
• ArcGIS Pro is Esri’s modern desktop GIS application designed for mapping, 

spatial analysis, and data visualization. It offers a streamlined interface, 64-bit 
performance, and integration with ArcGIS Online for sharing and 
collaboration

• Part of the ArcGIS platform, integrates with ArcGIS Online and Enterprise for 
cloud-based workflows, and for sharing and collaboration

Key Benefits
• High Performance: Optimized for large datasets and complex analysis
• Scalable: Works for individuals, teams, and enterprise-level deployments
• Interoperability: Connects with other Esri products and external data sources

ArcGIS Pro Overview



Key differences between ArcMap and ArcGIS 
Pro:
• Modern interface

• Ribbon-based design
• 64-bit architecture for better 

performance
• Modern GIS Software

• All GIS tools located in one place
• Integration with ArcGIS Online and Portal

• Migration into Pro
• Use the Project Migration tools
• Update an MXD in Pro

Key Differences

Feature ArcMap ArcGIS Pro

Architecture 32-bit 64-bit

UI Design Classic Menus Ribbon Interface

3D Support Limited Full native

Cloud 
Integration

Minimal Strong

Performance Slower Faster

Future Support Legacy
Current & 
Future



ArcGIS Pro Concepts

Context SensitivityApplication LayoutProject-Based

What is a Pro Project?
• A Pro Project organizes all your maps, layouts, data connections, and tools in one 

workspace. Creating a project ensures consistency and makes it easier to manage 
resources. Projects typically include a default geodatabase and toolbox for storing data and 
workflows.



Storage Options
• File Geodatabase: Local, single-user, efficient for 

analysis
• Enterprise Geodatabase: Multi-user, versioning, 

collaboration
• Cloud Services: ArcGIS Online for sharing and scalability

Choosing the Right Storage
• Consider data size, editing needs, and collaboration
• Local projects → File Geodatabase
• Enterprise workflows → Enterprise Geodatabase
• Distributed teams → Cloud-based storage

Class Exercise 1

Data Storage in ArcGIS Pro



Getting Started with an 
ArcGIS Pro Project
Module 2



• Choose Basic, Standard, or Advanced based on functionality needs and budgetary 
restrictions

• Use Named User for flexibility and modern workflows
• Single Use is best for offline or standalone setups
• Concurrent Use previously allowed multiple users to share licenses via ArcGIS 

License Manager
• No longer supported for versions after ArcGIS Pro 3.6 (and will be fully retired 

for future releases) - plan migration now!

Licensing



• ArcCatalog (Catalog) is integrated in ArcGIS Pro
• No standalone mode, requires ArcGIS Pro
• Interface is modernized
• No longer called “ArcCatalog”, just simply “Catalog”

• Enhancements
• Can be opened as a pane or a full window
• Supports cloud and Portal with direct access to ArcGIS Online, Living 

Atlas, and Enterprise portals
• Can combine data management with analysis and visualization

Where is Catalog?



Where is Catalog?

ArcCatalog
ArcGIS Pro Catalog View



• Projects are saved using the Save Project option in the top left corner
• Just like ArcMap, this will only save visual changes made in the project

• With ArcGIS Pro, you are always in active edit session
• Unlike ArcMap where you had to start an edit session on a specified GDB
• Toggling edit session option is available in ArcGIS Pro

• Can edit multiple GDBs at a time
• Edits relating to data modifications must be saved within the Edit ribbon

Saving Edits and Projects



• From a Local or Network Drive
• Shapefiles, file geodatabase, raster data

• From an Enterprise Geodatabase
• Use the Database Connections located in Catalog

• Right Click Databases – Add Database Connection
• Enter credentials

• Add feature classes, tables, or views
• From ArcGIS Online or Portal

• Requires ArcGIS Online login or Enterprise Portal account
• Add hosted feature layers and map services directly to your map

• From ArcGIS Living Atlas and ArcGIS Online
• Access publicly available datasets

• From Excel or CSV Files

Accessing Data in Pro



MXD
• File Type: .mxd stands for Map Document
• Purpose:

• Stores map layout and symbology
• References to data sources (but not the 

data itself)
• Structure: Each MXD contains one map view 

(though you can have multiple data frames)
• Behavior: If you move data outside its original 

location, MXD may break links because it uses 
relative or absolute paths

MXD vs APRX
APRX
• File Type: .aprx stands for ArcGIS Project
• Purpose: Stores Multiple maps (2D and 3D), 

Layouts, tasks, styles, and connections
• Structure: A single APRX can contain many map 

views, scenes, and layouts
• Behavior: Uses project-based organization with 

a default geodatabase and toolbox. Paths are 
managed more robustly than MXD



Don’t worry! Your saved MXDs can be imported into ArcGIS Pro.

Steps
• Open ArcGIS Pro, select “start without a template”
• Under the Insert tab, select “Import Map”
• Navigate to the location of the saved MXD and load
• MXD will appear as an ArcGIS Pro Map titled “Layers” due to the conversion. This 

can be renamed via the Contents Pane or Catalog Pane
• Symbology, labelling, and editing for the converted MXD can now be performed in 

ArcGIS Pro

Import MXD into Pro Project



Geoprocessing Tools
• Convert Map to Pro Project: Automates conversion of multiple MXDs into Pro projects
• Batch Import: Useful for organizations migrating large numbers of maps

Data Validation and Repair
• After migration, use Repair Geometry and Validate Topology tools to ensure data integrity
• Check for broken paths using Repair Project or Update Data Sources

Python Migration
• ArcGIS Pro uses Python 3, while ArcMap uses Python 2
• Scripts may need updating for compatibility (e.g., print statements, library changes)

Best Practices
• Start with smaller projects to test migration
• Use Esri’s Project Migration Checklist for a smooth transition
• Validate symbology and labeling after import

Class Exercise 2

Other Migration Tools

https://www.esri.com/content/dam/esrisites/en-us/media/misc/user-type-migration-guide.pdf


Map Interface
Module 3



• ArcGIS Pro is designed with a ribbon-based interface for intuitive navigation and 
productivity

• Ribbon Interface: Located at the top of the application, organized into tabs
• Key Tabs:

• Map: Tools for navigation, adding layers, and managing map views
• Insert: Add new maps, layouts, and data frames
• Analysis: Access geoprocessing tools and spatial analysis functions
• View: Manage panes, windows, and multiple map views
• Contextual Tabs: Appear based on selected items (e.g., layer-specific tools)

Exploring Ribbons



Application organization in ArcMap vs ArcGIS Pro:
• Ribbon format vs toolbars
• Multiple layouts and views in ArcGIS Pro
• Catalog and Content Pane

Application Layout Changes



• Catalog is a central location for managing GIS data in ArcGIS Pro
• Provides access to maps, layers, databases, and tools
• Organizes resources for efficient project management

Catalog



• Catalog can be accessed through the ‘View’ ribbon and can be opened as 
Catalog View (full screen view of Catalog – below image) or Catalog Pane 
(docked window for quick access – right image)

• Expand folders and databases to locate data
• Search functionality helps find specific resources quickly

Navigating Catalog



• Preview spatial and tabular data in the Catalog pane
• Check attribute tables and geometry before adding to map
• Supports multiple formats like shapefiles, geodatabases, and rasters
• Drag and drop data from Catalog into the map view

• Use 'Add Data' button for precise selection
• Ensure coordinate systems match for proper alignment

Viewing and Adding Data in Catalog



• Import tables, shapefiles, and data into geodatabase
• Export layers to different formats for sharing
• Use geoprocessing tools for batch operations

Importing and Exporting Data



Contextual Tabs in Pro
• The UI in pro is dynamic, with features becoming available depending on 

workflow
Class Exercises 3-5

Context Sensitivity



Symbology and Labeling
Module 4



• Symbology is no longer contained in the Layer 
Properties

• Symbology type enhancements (heat maps, vector 
tile support)

• GPU based rendering vs CPU based rendering (faster, 
more dynamic)

• Advanced options in ArcGIS Pro
• Multivariate symbology allows combining 

multiple attributes in a single visualization
• Symbol Effects like transparency, rotation, scale, 

3D
• Dynamic symbology allows adjustments based 

on map scale or attribute values

Symbology



Symbology
• Symbology within ArcGIS Pro can be accessed through the Feature 

Layer ribbon of a selected feature class
• The Symbology pane will appear with the options to adjust the 

layer’s symbology
• Select the symbol image to open the Gallery and Properties 

options which allow you to adjust the color, size, shape, and more
• Save customized symbology to be a part of your “Favorites” for 

quick access in the future



• Labeling is no longer contained in Layer 
Properties

• Labeling can be accessed in the Ribbon when 
the layer is selected in the Contents pane or by 
right clicking the feature class and selecting 
Labeling Properties

• Expressions can be written in Arcade, Python, or 
VBScript

• Allows multiple label classes and scale – 
dependent visibility

Labeling in ArcGIS Pro



Labeling Syntax
Expressions can be written in Arcade, Python, or VBScript
VBScript (being deprecated)
• Field delimiters: Field names are enclosed in square brackets [FIELDNAME]
• Concatenation: The ampersand (&) operator is used to join strings, fields, and text. Text will use double quotes (“) to surround 

the values.
• Example: [FIELD1] & " " & [FIELD2]

• Line breaks: Must use & vbnewline &

Python
• Field delimiters: Field names are enclosed in square brackets [FIELDNAME]
• Concatenation: The plus sign (+) operator is used to join strings, fields, and text. Text will use double quotes (“) or single quotes 

(‘) to surround the values.
• Example: [FIELD1] + ‘ ‘ + [FIELD2]

• Line breaks: Must use + ‘\n’ +

Arcade
• Field delimiters: Field names are formatted as $feature.NAME
• Concatenation: The plus sign (+) operator is used to join strings, fields, and text. Text will use double quotes (“) or single quotes 

(‘) to surround the values.
• Example: $feature.NAME + " - " + $feature.TYPE
• Line breaks: Must use + TextFormatting.NewLine +

Class Exercises 6-8



Data Management
Module 5



Database Management

Feature ArcMap ArcGIS Pro

Domain Tools
Limited, mostly manual via 
ArcCatalog

Full geoprocessing tools for 
domains and automation

Subtypes Manual setup Geoprocessing tools available

Attribute Rules Not supported Supported with automation

Versioning Traditional only Traditional + Branch versioning

Integration Standalone
Integrated with ArcGIS 
Online/Enterprise



• Create Domain, Delete Domain, Table To Domain for domain 
operations

• Assign Domain To Field for automated domain assignment
• Create/Alter/Delete Subtypes for subtype management
• Add/Remove Attribute Rules for advanced validation
• Enable/Disable Branch Versioning for multiuser workflows
• Create/Alter/Delete Relationship Class for table relationships
• Create/Alter/Delete Geodatabase for file or enterprise 

geodatabases
• Copy/Export Geodatabase Schema for schema migration

Pro Tip – the geoprocessing toolbox is equipped with its own 
search function!

Database Management Geoprocessing Tools



Fields View
• A dedicated interface for managing fields. 
• Accessed by right-clicking a layer or table → Design → 

Fields
• Displays all fields in a grid with properties like name, alias, 

data type, length, default value, and domain 
Adding and Removing Fields
• Add new fields directly in the Fields View
• Delete fields (if allowed by schema rules)
• Changes are applied when you click Save
Editing Field Properties
• Modify field name, alias, data type, length, default values, 

and nullable settings
• Assign domains and subtypes for data integrity

Field Management



Advanced Features
• Attribute Rules: Automate calculations or enforce constraints
• Contingent Values: Define valid combinations of field values
• Field Groups: Organize fields for better editing experience 
• Integration with Geoprocessing Tools
• Tools like Add Field, Delete Field, Alter Field, and Assign Domain To Field allow 

automation in Model Builder or Python
• Copy and paste fields from different feature classes

Advanced Field Management



Attribute Rules
• Purpose: Automate calculations and enforce constraints at the geodatabase level
• Types of Rules: 

• Calculation Rules: Automatically populate or update field values (e.g., calculate area when 
geometry changes)

• Constraint Rules: Prevent invalid edits (e.g., disallow negative population values)
• Validation Rules: Flag errors for review without blocking edits
• Implementation: 

• Rules are written using Arcade expressions
• Applied to feature classes or tables in an enterprise or file geodatabase

• Benefits: 
• Improves data quality
• Automates repetitive tasks
• Works in multiuser environments with branch versioning

Advanced Field Management



Contingent Values
• Purpose: Define valid combinations of field values to ensure logical consistency
• Example: If RoadType = Highway, then SpeedLimit must be between 55–75 mph. If RoadType = 

Residential, then SpeedLimit must be between 20–35 mph
How It Works: 

• You create Field Groups in the geodatabase
• Within each group, you define contingent values for fields
• When editing, the system restricts choices based on these rules

Benefits: 
• Reduces data entry errors
• Enforces business logic without custom scripts

Advanced Field Management



ArcMap
Open ArcCatalog or Catalog Window

• Navigate to your geodatabase
• Right-click Geodatabase → Properties

Domains Tab:
• Click Add Domain
• Enter Name, Description, Field Type, and 

Domain Type
Add Values:

• For coded domains: Add code-value pairs
• For range domains: Specify min/max
• Click OK to save

Assign Domain:
• Open Feature Class Properties → Fields Tab
• Assign domain to the desired field

Domain Management
ArcGIS Pro
Open ArcGIS Pro and load your project
Open Catalog Pane → Navigate to geodatabase

• Right-click Geodatabase → Domains
Create Domain:

• Enter Name, Description, Field Type, and 
Domain Type

Add Values:
• Coded or range values
• Choose Split Policy → Duplicate or Default
• Save Changes

Assign Domain:
• Open Feature Class Properties → Fields View
• Assign domain in the Domain column

Optional: Configure Attribute Rules or Contingent 
Values for advanced validation



ArcGIS Pro - Domains are managed directly 
within the ArcGIS Pro Project

Domain Management
ArcMap - Domains are managed by accessing 
Database Properties in ArcCatalog



Topology
ArcMap

ArcGIS Pro

Tips for ArcMap Users
• Topology toolbar in ArcMap → replaced by Error Inspector and Modify 

Features in Pro
• Topology layer symbology is similar but managed in the Contents pane
• Batch rule creation is easier in Pro with the Properties dialog

Class Exercises 9 and 10



Exploring Attribute Tables
Module 6



ArcMap: 
• Separate Window: Tables open in floating windows, less integrated with the main interface.
• Limited Filtering: Basic selection and query tools, no quick search bar
• Field Management: Field calculator and joins are available but less streamlined
• No Tabbed View: Each table opens in its own window
ArcGIS Pro: 
• Dock-able & Multi-Tab Interface: Attribute tables open in a tabbed view, allowing multiple tables to 

be docked and switched easily
• Dynamic Filtering & Selection: Includes quick filters, selection tools, and interactive highlighting
• Search Bar: Instant search within the table. Find and replace data quickly
• Field Management: Add, delete, and calculate fields directly from the table or the ribbon
• Integration with Tasks & Geoprocessing: Attribute table operations are tightly integrated with the 

ribbon and geoprocessing tools

Attribute Tables



Use “Select by Attributes” for a more intuitive and user-friendly way of querying data
• ArcGIS Pro includes an interactive expression builder
• SQL and Arcade can be used for advanced logic

Syntax Differences
• ArcMap Syntax: VBScript and Python
• ArcGIS Pro Syntax: VBScript, Python, Arcade

Queries

ArcGIS Pro ArcMap



Supports multiple scripting languages: 
• Arcade - dynamic, map-aware expressions
• Python - powerful for complex calculations
• VBScript - legacy support

Integration with both the attribute table and the ribbon

Field Calculations

ArcMap
ArcGIS Pro



Editing Tools
Module 7



ArcMap: 
• Editing is done through the Editor toolbar
• You start and stop editing sessions manually
• Tools are spread across multiple toolbars and menus
• Undo/Redo is limited to the current editing session
• Versioned editing requires manual reconcile and post steps
ArcGIS Pro: 
• Editing tools are integrated into the Edit tab on the ribbon
• No need to start/stop editing sessions explicitly—edits are tracked automatically 
• Contextual tools appear based on the selected feature type
• Unlimited Undo/Redo across multiple layers and operations
• Better integration with branch versioning for enterprise geodatabases

Key Differences - Editing



The Edit tab provides all the commands needed for creating and modifying spatial data.

Edit Ribbon

1. Clipboard – Handles copying and pasting features. Quickly duplicate or move features between layers or maps.
2. Manage Edits – Controls editing environment and settings. 

• Note: There’s no manual “start/stop” edit session—editing begins automatically when you modify data and 
ends when you save or discard edits.

3. Snapping – Ensures precise alignment of features during editing. Prevents gaps or overlaps by snapping vertices to 
other features within a specified distance.

4. Features – Create, modify, and manage features templates. Opens pane with templates for feature creation and 
contains the full collection of tools for editing existing features.

5. Selection - Controls how you select features for editing and allows you to isolate features within map. Opens 
Attributes pane for selected features to perform attribute edits.

6. Tools – Provides a quick access to the editing tools



ArcGIS Pro consolidates these tools into a modern, ribbon-based interface with contextual options, better snapping, 
and topology-aware edits, making workflows faster and more precise compared to ArcMap’s older toolbar approach.

Editing Tools

ArcMap

ArcGIS Pro



• Tools are organized into groups like Features, Tools, and Modify, making workflows more 
intuitive compared to ArcMap

• Line editing in ArcGIS Pro is more interactive, precise, and integrated with advanced tools 
compared to ArcMap.

• Supports modern workflows like snapping, topology, and attribute rules
• ArcGIS Pro offers real-time previews, undo/redo history, and multi-threaded performance

Line Editing

Class Exercise 13



ArcGIS Pro Enhancements
• Reshape, Divide, and Align tools located in Modify Features

• Allows freehand or segment-based reshaping of polygon edges with precision
• Divide tools can splits polygons using a drawn line or another feature, with snapping and 

alignment options
• Supports multiple splits in one operation
• Multiple tool options for different workflows
• Aligns polygon edges to other features or guides for clean topology

ArcMap Tools
• Reshape (basic): Limited to adjusting vertices manually; less intuitive than Pro’s dynamic 

reshape.
• Cut Polygon: Splits polygons by drawing a line, but lacks advanced snapping and alignment
• Merge: Combines polygons into one feature, but requires multiple steps and manual attribute 

handling

Polygon Editing

Class Exercise 14



Advanced Editing
• Align Features tool

• Reshapes features to be contiguous with other features based on a sketched line that is 
traced along existing feature segments

• Located within the Alignment group of the Editing Tools
• Autocomplete Polygon

• Create an adjoining polygon using an existing polygon in the same layer to complete the 
coincident edges

• Located within the Create Features window
• Extend or Trim

• Extends or trims line features to an existing feature boundary
• Located within the Reshape group of the Editing Tools

• Transfer Attributes
• Uses the current field mapping settings to copy attributes from features in a source feature 

layer to corresponding features in a target feature layer
• Located within the Attributes group of the Editing Tools



Best Practices and 
OK Toolkit Overview
Module 9



Creating a Quality Assurance (QA) Culture
• QA enforces those best practices

• Stakeholder engagement

• Business needs for data - who 
manages

• NG9-1-1 Education

• Improving existing workflows

• Iterative validations on NG9-1-1 data

• NOT a one and done

• Scheduled - may need more 
frequently if increased editing and 
adding data



• Maintain required fields within data
• Be mindful of how other features impact data attributes
• Address point within road range - ranges may require adjusting when 

address points are added or removed
• Breaking road centerlines at boundaries and updating attributes 

appropriately
• Parse address elements
• Standardize attributes
• Leverage domains to reduce inconsistencies and errors
• Avoid blank values in data and replace with NULL

Best Practices



• Use the Command Search!
• Use Field Calculator “helpers” to perform quick updates
• Save your feature symbology to be used in the future without having to configure
• Import Symbology from other layers
• Drag and drop folders from File Explorer directly into the Catalog Pane to quickly 

make folder connections
• Utilize the Quick Access Toolbar for all your favorites
• Instead of searching in the ribbons, right click the map to activate “Select Features” 

tool, “Explore cursor” tool, and others
• When editing vertices, press the keyboard space bar to temporarily turn off snapping 

while editing
• Use the Attribute window to edit fields with domains

Tips and Tricks in ArcGIS Pro



• Newest version of the OK Toolkit has been released and can 
be downloaded from the GIC site: 
https://www.okmaps.onenet.net/address_standards.htm

• OK Toolkit v3 is built for ArcGIS Pro and uses the newest 
NG9-1-1 and Address Standard Schema

• Layout of the toolkit categories and tools have been 
condensed and simplified from previous versions

• The OK toolkit must be incorporated in your QA/QC process 
and data will be required to be submitted to the OK 
Repository on a quarterly basis

The State will release more information regarding upcoming trainings!

Oklahoma NG9-1-1 GIS Toolkit v3
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