Transition to ArcGIS Pro
State of Oklahoma Training
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Transition to ArcGIS Pro

ArcGIS Pro Overview
Exercise 1
e Launch ArcGIS Pro
e Open ArcGIS Pro from your desktop or start menu
e Start a New Project
e On the Start Page, click New Project
e Choose a Project Template: ‘
e Map: Creates a project with a default = v m
map '
e (Catalog: Creates a project focused on
data management
e Global Scene or Local Scene: For 3D visualization
e Select Map for this exercise
e Name and Save the Project
e Inthe Create a New Project dialog:
e Enter a Project Name (ex: GIS_Pro_Training)
e Choose a Location where the project folder will be stored
e Optionally, check Create a new folder for this project
e Click OK

New Project

Getting Started with ArcGIS Pro Project
Exercise 2
e Data management using Catalog.
o Unlike ArcGIS Desktop, ArcCatalog is no longer a standalone program. It can be
found embedded within ArcGIS Pro.

Project Map Insert Analysis View Edit Imagery Share Help

AR [—~~ |—\— ‘ ‘ (&) Catalog Pane
* : ‘ e = Catalog View Python Window t v

& Geoprocessing Workflow » v

Convert Link Link Reset
v Viewsv Cursors Panes vJi=] Contents

View Link Windows

o Open ArcCatalog within ArcGIS Pro by clicking on the View tab and selecting
“Catalog View" to see a full view of the Catalog or “Catalog Pane” to have a
minimized view docked on the right side of the window.

o Within Catalog View mode, the Catalog Tree is on the left and contains the folder
structures in which the GIS data is stored.

¢ Navigate to the Folder with the Course Data and click the ArcGISProTraining.gdb
geodatabase.
e Expand the > next to the geodatabase to expand the contents
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e Click the Road Centerlines in the Catalog Tree and explore the data
o On the right there are three tabs: Metadata, Geography, Table
» Click on the Metadata to see any metadata associated with the feature
class.
» (lick on the Geography tab to see a preview/geometry of the feature
class.
= C(Click on the Table tab to see the attribute table of the feature class.
e Saving Pro Project and Edits
e Pro Project can be saved in the top left corner of the project. Note, this form of
saving only saves the project with the interface and visual adjustments.
e Saving edits can be found within the Edit ribbon and will save any edits made to
the data.
o Key Navigation Differences
e Identify (ArcMap) vs Explore (ArcGIS Pro)
e Table of Contents (ArcMap) vs Contents (ArcGIS Pro)
e What other tools are you familiar with in ArcMap?
e Single data frames vs. Multiple layouts
e Project > Options
e Update Editing options
e Update Save options
e Update Selection options
o Define default project locations

Options m] e
A ~ UeTault tool When geactivating editing tools:
Project < -
®) Explore
Current Settings P
Select

Units

Tasks v Session
Application Enable and disable editing from the Edit tab

General ®

Map and Scene

Navigation Automatically save edits

Selection

() 10

Editing

Versioning 30
Geoprocessing Save edits when saving project

ModelBuilder Show dialog to confirm save edits

Device Location Show dialog to confirm discard edits

Catalog Browsing Deactivate an active editing tool when saving or discarding
Share and Download +| Make newly added layers editable by default

Authentication .
¥ Annotation

Raster and Imagery
Full Motion Video » Symbology
Display

Learn more about editing options
Table
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Map Interface
Exercise 3
Navigate Ribbons
e Map Ribbon
e Add data layers through ‘Add Data’
e Navigate to provided geodatabase named ArcGISProTraining.gdb
Add a basemap
Create a bookmark within the map
e Reorder, Update and delete Bookmarks
e Export Bookmarks
e Import Bookmarks
Choose the Select tool and select a group of features, adjust selection types
e Change the view within Contents pane to List by Selection to see selected
feature counts and layers
Test the ‘Measure’ tool
e Insert Ribbon
e Add 'New Map’ and ‘New Layout’
e Import a saved .mxd into project

. On the Insert ribbon Project Map Insert Analysis View Edit Imagery g
choose Import Map | ‘ Ty | By (] New Presentation (4] Import Map +f31 5 =+
. . " i New Notebook ~ =] Import Layout ~ —
New  New New Connections  Add
¢ SeIeCt prOVIded de ﬂle Map v Layoutv Reportv & Toolbox v I:: Task ¥ v Folder
'OKTraining.mxd' to Project
import
Exercise 4
e Inthe Ribbon, navigate to "View" and find the catalog pane in the “Windows" section to
open
e Inthe catalog pane under the "Project” tab, find the file Catalog v X
organization preset titled “Maps” Project Portal Computer Favorites =
e Right-click on “Maps” to create a new map. Notice that 7 | search Project P~
you are given the option to create Scenes as well (3D) \D_ | NewNiap S
e When a new map is created, it is automatically brought + o 7 B NewGlobal Scene
into the project. Notice that you can toggle between the b g 4 NewLoce! scene
two views that now exist in the same project file “f5 D
e The new map can be renamed by right-clicking in the ' L?: = NewBasemz
4 s Sl
catalog pane and selecting “rename @ & oo
e In the Contents Pane, under Drawing Order, the name of et
the new map will appear and list data associated with P ArciS 3D
h f G» ArcGIS Colors
that SpeCI ICc map G¥ ColorBrewer Schemes (RGB)
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Exercise 5

* Navigate to the "“Map” tab in the ribbon. Under “Layer”, select “Add Data”

e Inthe "ArcGIS Online” folder, search for the layer Oklahoma Counties and add it to the
map

e Once the layer is added, in the “Contents” pane, select the Oklahoma Counties layer
and ensure it is highlighted in blue

e Once the layer is highlighted, notice the new items in the ribbon that appear — Feature
Layer, Labeling, and Data. These will only appear in the ribbon if an appropriate layer is
selected

Displaying Data
Exercise 6
e In the contents pane, right-click the Address Point layer and select Symbology
e Select the icon for Symbol. Review the options in the Gallery for programmed
symbology types.
e Change the color, size and halo effect
e Repeat for the Road Centerline Symbology
e Change to have an arrow at the end, edit the color, and size
e While in properties, select the 3 lines in the upper right-hand corner of the
symbology window
e Choose "Save symbol to style” and save the symbology you created to your
favorites
e The new style will appear in the Symbology Gallery
e Update the ESZ Boundary to symbolize by unique ESN values

Exercise 7
e Modify scale visibility of addresses and roads to appear with a maximum or minimum
scale
e Example: Address Points to draw only when zoomed in (=] Transparency | 0.0%

beyond 1:24,000 | Layer Blend |Norma
e Add transparency to a polygon layer - update the symbology
of your PSAP Boundary to have a transparency of 45%

&) Feature Blend|Norma

Effects

Exercise 8
e Add labels for address points and road centerlines
e Try using different syntax options
e Note: Python and VBScript can use double quotes “ when using free form text
e Update label zoom extents to have point labels appear at 1:8,000 and road labels to
appear at 1:15,000
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Project Map Insert Analysis View Edit Imagery Share H

5y Class | Default v Q SQL Query @ Maximum Scale | <None>
22 )
Label /| Label Features In This Class Minimum Scale 1:8,000
Field | <Expression= ~ | &) Expression 24 Clear Limits
Layer Label Class Visibility Range

o Create a second label Class to customize labeling further

Data Management
Exercise 9
Step 1: Prepare Your Data
e Topology works only in a geodatabase within a feature dataset
Step 2: Create a Topology
e Inthe Catalog pane, right-click the feature dataset > New > Topology
e Name your topology and set the cluster tolerance (default is usually fine)
o Add feature classes that will participate in the topology
e Assign rank (higher rank = less likely to move during validation)
Step 3: Add Topology Rules
o After creating the topology, right-click it > Properties
e Go to Rules tab > Add Rule
e Choose rules like:
e Must Not Overlap (for polygons)
e Must Not Have Dangles (for lines)
e Must Be Covered By Boundary Of (for polygons within polygons)
Step 4: Validate the Topology
e Add the topology to a map:
e Drag it from the Catalog pane into your map
e Go to Edit tab > Manage Edits > Validate
e Errors will appear in the Error Inspector pane
Step 5: Fix Errors
e Use Error Inspector to locate and fix errors
e Use Modify Features tools (e.g., Move, Reshape) to correct geometry

Exercise 10
Using Provided Excel File, plot the x,y coordinates to create a — .
. [ == & Add Data From Path
point layer | . _
e Within Map Ribbon, choose ‘XY Table to Point’ Doy ggd b IR

e Import the provided ‘SampleAddresses.xlsx’ table to v Datav g8 Add Graphics Layer
p p p

create new point feature class

Layer
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Exploring Attribute Tables
Exercise 11
o Select all addresses with a value of 'UNINCORPORATED' for the City
e Select all addresses with house numbers greater than 200
e Select all road centerlines with a Street name of value of ‘Willow" and a City value of

INOLA’
o Select all road centerlines that have a Left or Right range of “0-0"

[T \A Vall EZ Attributes
] B B B
Selecyl Select By [Select By i

~ | AttributesjLocation Zoom To

Sdlection [
Exercise 12

e Select all addresses with a County value of "BEAVER COUNTY” and field calculate to

"ROGERS COUNTY”
e Now, use the Attributes window (formerly ‘Attribute Editing Window' in ArcMap) to

apply the update

L‘C@ G\lz E[—'j =] Attributes

Select Select Byf Select By

«  Attributeqd Location Zoom To
e | ]
Editing Tools
Exercise 13
In ArcGIS Pro editing does not need to be turned on, and all feature classes can be edited at any
time.

¢ In the Edit ribbon locate the features group and click Create. This window should be
docked on the side of the screen.
¢ In the Edit ribbon navigate to the selection group and select Attributes to turn on the
Attributes editing window pane.
o Select ADDRESS_POINT and click in the map to place a point
» The attributes for the new address point are ready for population in the
Attributes window.
» Add the following address attribute information in the new address point:
e 148 N Main St Apt A Inola, OK USA
o Select ROAD_CENTERLINE and create the geometry for a road centerline
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» The attributes for the new road centerline are ready for population in the
Attributes window.
= Add the following attributes for the new road centerline:
e N Main St Inola, OK USA and range 100-155
Copy and paste an address point

Project Map

L, Cut

. () Copy
C\ipbo‘arc‘l
Select a Road Centerline, in the tools, choose Split. Double-click on the selected
segment to split the feature at that location.

o Select both the created split segments — open the attribute table. What do you

notice?

e Merge the two road centerlines back together
Select a Road Centerline, in the editor tools, choose Reshape Feature Tool. Click on the
selected RCL, next click within the map to place additional vertices to reshape the
segment. Double-click the selected road to end the drawing and complete the reshape.
Select a cul-de-sac segment and right-click and choose Edit Vertices > Reverse
Direction

e Formerly known as “Flip” in ArcMap

o Note, Edit Vertices can also be selected within the Edit Ribbon.
Make sure to save your edits!

Project Map Insert Analysis View Edit Imagery Share Feature Layer Labeling Data

L Cut , BF. |5 No Topolagy - S X Attributes ) O 1
r 1 } |’ 1 |
1 Copy ! @ status — Clear — ‘ i
= Save [ffscard Snapping | Create Modify Delete | Select Mave Annotation Edit Reshape Merge Split
1 Error Inspector - ~ @Y Zoom To Vertices
board Manage Edits

i Snapping eatures [ Selectior [ =
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Exercise 14
Select an ESZ polygon. Zoom to the border of the polygon and choose the Split Tool.
Click on the selected polygon edge, next click within the map to place additional vertices
to cut the polygon. Once the area has been outlined, double-click the selected polygon
edge to finish the cut.
o Select the newly created cut feature and the neighboring ESZ polygon — Merge
the polygons together to create a single feature.
Select the ESZ polygon with NGUID_ESZ = 'ESZ_BOUNDARY_4@cog.acog.ok.gov'.
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Explode this multipart boundary.

Reshape a boundary

Save your Edits!
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